电脑系统升级到windows11后,安装Dotfuscator 4.10 混淆.NET4.0的项目出现 “Could not find compatible version of ildasm” 错误
解决方法:
找到相应项目的Dotfuscator的xml文件,在

<dotfuscator version="2.3">
</dotfuscator>

中加入

<propertylist>
      <property name="ILDASM_v2.0.50727" value="C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\ildasm.exe" />
      <property name="ILDASM_v4.0.30319" value="C:\Program Files (x86)\Microsoft SDKs\Windows\v8.1A\bin\NETFX 4.5.1 Tools\ildasm.exe" />  
   </propertylist>

参考电脑上有没有此文件,C:\Program Files (x86)\Microsoft SDKs\Windows\v8.1A\bin\NETFX 4.5.1 Tools\ildasm.exe



如果您对C#游戏开发感兴趣,可以扫下面二维码加入我们的QQ群来一起学习交流

原创文章,转载请注明本文链接地址(违者必究):Dotfuscator混淆项目出现Could not find compatible version of ildasm错误